Brugtgrej.dk
Forside  |   Ny annonce  |   Forum  |   Nyhedsmails  |   Om brugtgrej  |   Kontakt Brugtgrej
91 online brugere
3041 online annoncer
SælgesKøbes

Bøvl med forbindelse fra Raspberry Pi


#1  01/04-24 11:46
Jørgen Kragh
Indlæg: 645
Nå venner,

Så er der et af de mere skumle spørgsmål.

Min Langstone V2 opførte sig underligt, så for at være sikker på, det ikke var en SW fejl, ville jeg lægge ny SW på helt fra grunden.

Det gik fint med at få OS på SD kortet og over i Raspi4, men når jeg SSH'er til den og beder den om at hente Langstone SW på github, går det galt.

Jeg får det svar vist nedenfor, at Raspi'en ikke kan komme i kontakt med github-serveren:

pi@raspberrypi:~ $ wget https://raw.githubusercontent.com/g4eml ... install.sh
--2023-02-21 10:00:40-- https://raw.githubusercontent.com/g4eml ... install.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... failed: Temporary failure in name resolution.
wget: unable to resolve host address ‘raw.githubusercontent.com’

Det sker på BEGGE mine PC'er, og det har stået på i flere dage. Jeg har naturligvis spurgt i det "autoriserede" Langstone forum hos BATC, men uden held.

Host PC'en havde ingen problemer med at kontakte github, og jeg fik fat i installationsfilen og fik den kopieret til Raspi'en, men så snart Raspi'en gik i gang med at hente programfiler, kom de samme beskeder, at der ikke var kontakt til serveren.

Noget kunne tyde på, at det er et eller andet i forbindelsen fra Raspi til PC (LAN) og videre derfra til min Yousee router, men hvad?

Er det PC'en der blokerer, og hvorfor så begge PC'er?

Vy 73

Jørgen

#2  01/04-24 11:55
Istvan Zarnoczay

Indlæg: 369
Svar til #1:
Hej Jørgen,

Blot et forslag. Prøv lige at få din mobiltelefon til at agere hot spot og forbind Raspien til github via den. Så kan du se om det er din firewall i din router det laver pjat med dig, Jeg havde en lignende problem med noget andet hvor det viste sig at min router ikke syntes at den tingest skulle ud på nettet.

----------
Istvan/OZ1EYZ
Livet er forkort til franske film og lave effekter

#3  01/04-24 14:14
Glenn Møller-Holst
Indlæg: 728
Svar til #1:

Pt er sitet ikke blokeret her:
https://urlhaus.abuse.ch/host/raw.githubusercont ent.com/

Men der bliver pt delt malware ud via raw.githubusercontent.com - se længere nede på siden.

----------
Glenn, OZ1HFT

#4  01/04-24 14:57
Carsten F
Indlæg: 33
Svar til #1:
Det lugter langt væk af at di ikke kan resolve dns navne på den maskine

Jeg resolver til følgende med: raw.githubusercontent.com

$ host raw.githubusercontent.com
raw.githubusercontent.com has address 185.199.108.133
raw.githubusercontent.com has address 185.199.109.133
raw.githubusercontent.com has address 185.199.110.133
raw.githubusercontent.com has address 185.199.111.133
raw.githubusercontent.com has IPv6 address 2606:50c0:8000::154
raw.githubusercontent.com has IPv6 address 2606:50c0:8001::154
raw.githubusercontent.com has IPv6 address 2606:50c0:8002::154
raw.githubusercontent.com has IPv6 address 2606:50c0:8003::154


kan du feks "pinge" dr.dk

$ ping dr.dk
PING dr.dk (95.100.155.187) 56(84) bytes of data.
64 bytes from a95-100-155-187.deploy.static.akamaitechnologies.com (95.100.155.187): icmp_seq=1 ttl=60 time=4.52 ms
64 bytes from a95-100-155-187.deploy.static.akamaitechnologies.com (95.100.155.187): icmp_seq=2 ttl=60 time=4.54 ms
64 bytes from a95-100-155-187.deploy.static.akamaitechnologies.com (95.100.155.187): icmp_seq=3 ttl=60 time=4.60 ms
64 bytes from a95-100-155-187.deploy.static.akamaitechnologies.com (95.100.155.187): icmp_seq=4 ttl=60 time=4.08 ms
64 bytes from a95-100-155-187.deploy.static.akamaitechnologies.com (95.100.155.187): icmp_seq=5 ttl=60 time=2.37 ms
64 bytes from a95-100-155-187.deploy.static.akamaitechnologies.com (95.100.155.187): icmp_seq=6 ttl=60 time=4.40 ms


Har du sat din Raspi til statisk (fast) ip , og glemt at indtaste.
default-gw og/eller dns server ip

Carsten


Redigeret 01/04-24 14:59
#5  01/04-24 15:45
Jørgen Kragh
Indlæg: 645
Svar til alle:

Tak for Jeres input.

Jeg har disablet WIFI i raspien for den skal jeg ikke bruge, men inspireret af Istvan satte jeg Raspi'en direkte i routeren og SSH'ede til den fra min radio PC. Nu var der ingen problemer med at hente filerne og installere Langstone SW.

Det peger i Carstens retning, for nu er PC'en ude af loppen. Det underlige er så, at det kørte fint for nogle uger siden, hvor jeg lavede en tilsvarende øvelse, og jeg har ikke pillet ved PC'ens indstillinger siden. Jeg kører ikke med statisk IP adresse, men jeg vil kigge på det, når jeg har fået opsat Langstonen.

Malware på raw.github. Tjaa det er der nok, men nu skal den her Raspi ikke på noget netværk, så hvis der er en eller anden der sidder i en snusket kælder og venter på at Raspie'en sender ham/hende/den/det noget interessant, ja så varer det sgu' længe.

Vi lukker tråden her.

Vy 73

Jørgen